Blocking Situs Porno Dengan Mikrotik Di Jam Tertentu Versi DNS Nawala

anti-pornoSebenarnya udah hampir 5 tahunan make mikrotik, tapi kalau mau nyetting ulang mesti liat catatan dulu.. haha 😀

 

Kali ini saya mau sharing tentang cara memblock situs porno dengan menggunakan mikrotik. Metode yang digunakan adalah menggunakan DNS Nawala.  Sebenarnya ada cara lain kayak metode keyword lewat proxy, atau metode redirectnya webproxy nya mikrotik. Sebagai tambahannya, pemblokiran dilakukan hanya khusus jam-jam tertentu saja, sehingga untuk jam lainnya bisa ngebuka yang macem-macem.. waawww 😀

Berikut ini persyaratan yang dibutuhkan :

  1. Mikrotik Versi 4.16
  2. DNS Nawala
  3. DNS Profider yang universal

 

 

Langkah pertama adalah membuat Jam mikrotik ini mengikuti jam internasional, kan gak lucu kalau suatu saat mikrotiknya bermasalah dan jamnya berubah otomatis schedule yang sudah dibuat jadi kacau. Caranya sebagai berikut :

 

Set NTP Client

Buka Winbox

Masukkan code berikut di terminal :

/system ntp client set primary-ntp=203.160.128.6 secondary-ntp=202.169.224.16 mode=unicast enabled=yes

 

Atau Lengkapnya seperti gambar berikut :

NTP Client

 

Langkah selanjutnya adalah membuat Script Blocking-nya :

Membuat Script Blocking (Mengaktifkan DNS Nawala)

Buka winbox

Masuk ke menu System – Scheduler dan buat jadwal baru serta  masukkan kode berikut pada kolom on event :

/ip dns cache flush
/ip dns set servers=180.131.144.144,180.131.145.145

Atau lengkapnya seperti gambar berikut :

Blocking Porn Schedule

 

Sedangkan untuk jam-jam bebasnya caranya sebagai berikut :

Membuat Script Unblocking (Mengaktifkan DNS Bebas)

Masuk ke menu System – Scheduler dan buat jadwal baru serta  masukkan kode berikut pada kolom on event :

/ip dns cache flush
/ip dns set servers=xxx.xxx.xxx.xxx,yyy.yyy.yyy.yyy

perhatikan xxx.xxx.xxx.xxx dan yyy.yyy.yyy.yyy merupakan DNS yang universal. Atau lengkapnya seperti gambar berikut :

Unblocking Porn Schendule

 

 

Pada kedua script diatas, perhatikan kolom Start Time dan Interval. Start Time berarti jam dimana jadwal ini diaktifkan, sedangkan Interval adalah durasi dimana jadwal akan dilakukan kembali.

 

Nah Langkah terakhir biar lebih maknyus adalah memaksa request DNS client untuk menggunakan DNS yang aktif sesuai jadwal diatas tadi, Rules nya cuma 2 barik kok, masukin aja berikut di IP – FIREWALL  – NAT  :

 

add action=redirect chain=dstnat comment="" disabled=no dst-port=53 protocol=tcp to-ports=53
add action=redirect chain=dstnat comment="" disabled=no dst-port=53 protocol=udp to-ports=53

 

 

Selesai deh 😀 😀 😀

One thought on “Blocking Situs Porno Dengan Mikrotik Di Jam Tertentu Versi DNS Nawala

  • May 19, 2013 at 8:23 PM
    Permalink

    wah,., kerenn,., thanks berad atas tutorialnya (y)

Leave a Reply

Your email address will not be published.